hacker.org Forum Index
RegisterSearchFAQMemberlistUsergroupsLog in
Challenge 'Glowing Referral'
Goto page 1, 2  Next
 
Reply to topic    hacker.org Forum Index » Challenges View previous topic
View next topic
Challenge 'Glowing Referral'
Author Message
hoki



Joined: 28 Oct 2008
Posts: 5

Post Challenge 'Glowing Referral' Reply with quote
Hey all,

I'm positive that I am loading the challenge with the required credentials, still it gives me

'http://whitehouse.gov/' is incorrect.

as an error message. Am I missing anything from the challenge description? Any hint would be most welcome :)

Thanks and a special 'thumbs up' to the maintainers of this site!

Hoki
Sat Nov 01, 2008 4:00 pm View user's profile Send private message
rmplpmpl



Joined: 26 Oct 2008
Posts: 113
Location: Germany

Post Reply with quote
I think you don't want the terminal slash to be there, try another tool
Sat Nov 01, 2008 6:03 pm View user's profile Send private message
hoki



Joined: 28 Oct 2008
Posts: 5

Post Reply with quote
Thanks a lot, that was exactly it. I thought the slash had been added server side, but it worked fine with that command line tool Smile Only thing I had to achieve first was to export the cookies from the Firefox DB so I could reuse them...
Sat Nov 01, 2008 7:45 pm View user's profile Send private message
PrincessQTPi



Joined: 03 Feb 2009
Posts: 5
Location: The Wired

Post Reply with quote
confused

_________________
Meow! =^.^=
Wed Feb 04, 2009 8:31 am View user's profile Send private message Send e-mail
hoki



Joined: 28 Oct 2008
Posts: 5

Post Reply with quote
PrincessQTPi wrote:
confused


Why exactly?

Cheers, Hoki
Wed Feb 04, 2009 8:47 am View user's profile Send private message
PrincessQTPi



Joined: 03 Feb 2009
Posts: 5
Location: The Wired

Post Reply with quote
all of it i have no clue what to do.

_________________
Meow! =^.^=
Wed Feb 04, 2009 9:20 am View user's profile Send private message Send e-mail
hoki



Joined: 28 Oct 2008
Posts: 5

Post Reply with quote
PrincessQTPi wrote:
all of it i have no clue what to do.


I think I can say that you should look out for an HTTP field that tells the server about where you are coming from. Then you have to figure out a way to modify it.

Cheers, Hoki
Wed Feb 04, 2009 1:49 pm View user's profile Send private message
Acitran



Joined: 19 Jul 2010
Posts: 3

Post Reply with quote
i always get the answer:
'' is incorrect.
what am i doing wrong?
Mon Aug 02, 2010 4:04 am View user's profile Send private message
Axxaran



Joined: 19 Jul 2010
Posts: 5
Location: Good ole Germany

Post Reply with quote
You dont get an answer if you don't send an answer...
Mon Aug 16, 2010 3:17 pm View user's profile Send private message
stormiii17



Joined: 29 Dec 2010
Posts: 1
Location: US

Post Reply with quote
can this be done in php? i'm so lost. ><
Fri Jan 07, 2011 9:10 am View user's profile Send private message
b0bA



Joined: 30 Dec 2008
Posts: 13

Post Reply with quote
stormiii17 wrote:
can this be done in php? i'm so lost. ><

Sure. You can use PHP, Python, Java, etc or even wget.
Fri Jan 07, 2011 10:51 am View user's profile Send private message
mukanga



Joined: 26 Nov 2010
Posts: 5

Post Reply with quote
Hi there! I'm a little bit lost too. I'm trying to submit the answer through wget like i did many times before. But I always get
Quote:
'' is incorrect

Even if I submit the answer through the site a get something like
Quote:
'http://www.hacker.org/challenge/chal.php?answer=http%3A%2F%2Fwhitehouse.gov&id=38&go=Submit' is incorrect.
Like i've submit all that answer Confused

So, can you tell me at least if this is normal or give me any tip?
Wed May 11, 2011 6:04 am View user's profile Send private message
SnakeSnake



Joined: 16 Oct 2010
Posts: 7
Location: germany

Post Reply with quote
mukanga: In this particular challenge the server does not look for the answer in the query string part of the URL but somewhere else. Finding out where is the challenge here...
Wed May 11, 2011 1:12 pm View user's profile Send private message
Millennium



Joined: 21 Apr 2011
Posts: 17

Post Reply with quote
-_- I actually went to whitehouse.gov, modified the HTML, and submitted to http://www.hacker.org/challenge/chal.php?id=38 from it. It returns: "'http://whitehouse.gov/' is incorrect"
Sun May 15, 2011 8:22 pm View user's profile Send private message
rmplpmpl



Joined: 26 Oct 2008
Posts: 113
Location: Germany

Post Reply with quote
This challenge is not so much about what you submit but from _where_ you do it... unless you have physical access to the White House you will need other ways to hack this one
Mon May 16, 2011 3:45 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    hacker.org Forum Index » Challenges All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.