Your Turn, Part Two

Forum Admin
Posts: 496
Joined: Sat May 28, 2011 9:14 am
Location: Germany

Post by AMindForeverVoyaging »

The point is I'm not sure if "no cookies" is a sensible restriction for a web challenge. In my opinion it is not. In your opinion maybe it is. If adum or some other moderator were around, we could have a discussion about what restrictions there should be and which there should not be, but unfortunately there is no 'official guy' available for such discussions.
Posts: 17
Joined: Wed Feb 05, 2014 12:21 pm

Post by Tabun »

I'm okay with this challenge. It requires some debugging if you approach it the easy way. It's not that hard to work around. This is not am accredited web development course, it's a hacker challenge. :]

[edit: removed some stuff after I discovered this was not the 'solved' thread]
Posts: 16
Joined: Tue Aug 28, 2012 5:22 pm
Location: Italy

Post by meis »

I wasn't expecting to get stuck in this challenge, since it seems fairly easy, but... here I am.

I'm using Postman to test my API, and it seems to work perfectly, then i submitthe challenge and suddenly it doesn't execute the code. The request arrives, but it seems to stop for no apparent reason (I activated all possible CORS for that page.)

The log reads: (I had to put it in a link otherwise the reply generated a 501 error)

As you can see, the request of 15:03 comes from Postman, while the request from 15:10 comes from
The postman one executes correctly, while the one from here doesn't do anything (by that I mean that in the first lines of code I log the request in a SQL table, the one from postman gets logged, the other one doesn't). I thought it was a matter of cross-domain request blocking policies, but they should all be disabled for that only page. Also, if Postman works, any external service should work.

Am I missing something obvious?
User avatar
Posts: 9
Joined: Sun Jun 15, 2014 4:42 am

Post by Niker »

Got stuck as well, tried spinning up an AWS lambda + api gateway + cloudfront dist and running a local ngrok server from my laptop, but both approaches just throw a `'error' is incorrect.` without actually reaching the endpoints.
do the lala
Post Reply